Chapter 4.

SECTION I: REVOLUTION AND DESIGN
ENVIRONMENT OF VISUAL BASIC 2005

Getting Started With The IDE

The easiest way to write code in Visual Basic 2005 is by using the Visual Studio 2005
Integrated Development Environment (IDE). The IDE provides a wealth of features that are
unavailable in ordinary text editors such as code checking, visual representations of the
finished application and an explorer that displays all of the files that make up a project. An
IDE is a way of bringing together a suite of tools that make developing software a lot easier.

Start Page Of IDE

The Start page appears when Visual Studio 2005 is started. The Start Page provides a
centralized location to begin work using Visual Studio 2005. The Start Page can also be
started by selecting View > Other Windows > Start Page via the menu bar. The Start
page is the default home page for the Web browser in Visual Studio 2005.
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Diagram 4.1: The Start Page of Visual Studio 2005
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Solutions And Projects

Visual Studio 2005 provides two containers viz. Solutions and Projects to enable the IDE to
apply its wide range of tools, templates, settings and so on.

Solutions and projects contain items that represent the references, data connections, folders
and files that are needed to create an application. A solution can contain multiple projects
and a project typically contains multiple items.

A project includes a set of source files, its related metadata such as component references
and build instructions. Projects generally produce one or more output files when built.

A solution includes one or more projects, its files and metadata that help define the solution
as a whole. A solution is automatically generated when a new project is created. As and when
need arises other projects can be added to the solution.

Solution Explorer provides a graphical view of the entire solution that helps managing its
projects and files as the application is developed.

What Is A Solution?

Solutions manage the way Visual Studio 2005 configures, builds and deploys sets of related
projects. A solution can include just one project or several projects built jointly by the
development team. Sometimes a complex application might require multiple solutions

Solution allows concentrating on developing and deploying the projects, instead of sorting
through all the details of managing project files, components and objects. Each solution
allows:

0 Working on multiple projects within the same instance of the IDE

0 Working on items using settings and options that apply to an entire set of projects
0 Using Solution Explorer to help develop and deploy an application

0 Managing additional files opened outside the context of a solution or the project

Visual Studio 2005 stores the solution definition in two files i.e. .sln and .suo.

The .sln file stores the metadata that defines the solution:

0 Projects associated with the solution

0 Items available at solution level but not associated with a particular project
0 Solution build configuration
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The .suo file holds the metadata and properties to customize the IDE whenever the solution
is active. For example, Solution Explorer displays a Miscellaneous Files folder for a solution if
that option is enabled and the appropriate tools from the Toolbox becomes available for the
type of projects included in the solution.

REMINDER

% The .sIn file can be shared between developers in a development team. The .suo
file is a user specific file and therefore, cannot be shared between the developers
of a development team.

The .suo file is a hidden file that is not displayed with the default Windows
Explorer settings.

What Is A Project?

A project is used as a container within a solution to logically manage, build and debug the
items that form an application.

The output of a project is usually an executable file (.exe), a dynamic link library file (.dll) or
a module.

A project can be simple or complex as per the needs to meet the requirements. A simple
project might consist of a form or an HTML document, source code files and a project file.
More complex projects might consist of these items plus database scripts, stored procedures
and references to an existing XML Web Services.

All Visual Studio 2005 development products provide a number of pre-defined project
templates. Use any one of the many project templates to create the basic project container
and a preliminary set of items that might be needed to develop the application, class, control
or library. For example, if a Windows application option is chosen, the project offers a
Windows form item. Likewise, if a Web application is chosen, the project offers a Web form
item.

Each project template creates and maintains a project file to store the metadata specific to
that project. This project file is created and maintained while working within the IDE. The
extension of the project file and the actual content is determined by the type of project it
defines.

In general, the project file stores the configuration and build settings specified for the project
and its set of items. Some projects keep a list and location of the files associated with the
project.

When an item is added to a project, the location of its physical source file on disk is also
added to the project file. When the link is removed from the project, this information is
deleted from the definition file. Each project template determines which commands are
available for each item.
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What Are Items?

Items can be files and other parts of the project such as references, data connections or
folders. In Solution Explorer, items can be organized in the following ways:

0 As project items, which are items that compose a project such as forms, source files and
classes within a project in Solution Explorer. The organization and display depends on the
project template selected as well as any customization done

0 As solution items, which are files that are applicable to the solution as a whole in the
Solution Items folder of the Solution Explorer

0 As miscellaneous files, which are files that are not associated with either a project or a
solution but are displayed in Miscellaneous Files folder

Creating Solutions And Projects

Creating Solutions

To create a new solution, invoke Visual Studio 2005, select File > New Project. New
Project dialog box appears as shown in diagram 4.2.1. On the left hand side of the dialog
box the Project types are available. These project types are available for every language
included in Visual Studio 2005.

On the right side the Templates for the selected project type are displayed. A project
template helps getting started by creating a few initial files, codes and other settings for the
selected project type.

Currently under Visual Basic, Windows project type is selected and the Templates
available under the Windows project type are displayed.

Hew Project @
Templates: EE
s Visual Studio installed templates (e
Windows
+ evice — F f
Ve ;VE ‘;VE
Database =] ;_];-\"la g £l her
Sareris WindoWwsY Classlibrary  Console Windows b Control
- Other Languages Application Application  Control Library Library
+- Other Project Types
Ve Vg S vVa
Windows Empty Project Crystal
Service Reports...
My Templates
e )|

A project for creating an application with & Windows user interface

Name: WindowsApplication 1

Diagram 4.2.1: New Project dialog box

Under the Project types, select Other Project Types > Visual Studio Solutions. Under
the Templates select Blank Solution as shown in diagram 4.2.2
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Enter an appropriate name for the solution. If necessary change the location of the solution
directory by selecting L2ewse | and then specify a new location. Click L2 | when done.

After creating an empty solution, new or existing projects and items can be added to an
empty solution by using Add New Item or Add Existing Item from the standard toolbar.

New Project
Project types: Templates: EHE=
(®- Visual Basic Visual Studio installed templates
- Other Languages
(=) Other Froject Types :l
Setup and Deployment L
Ehitshens: Blank Solution
Extensibility
wisual Studio Solutions
My Templates
Search Online
Templates. ..

Create an empty solution containing no projects

Name: FirstSolution

Location: F:\Projects ~] £

Diagram 4.2.2: Selecting Blank Solution

Creating A Project

To start with a new project, select File > New Project. New Project dialog box appears

as shown in diagram 4.2.3.

Currently Under Visual Basic, Windows project type is selected and the Templates

available under the Windows project type are displayed on the right side.

Mew Project @

Project types: Templates: EHE=E

(=) Wisual Basic Visual Studio installed templates [ |
Windows

& Smart Device == F F
= Ve L Vg aVp
Database = ;_];.va g # b

Starter Kits windows Class Library Console windows  Weh Control
# Other Languages Application Application  Control Library Library

[#1- Other Project Types
Ve Vg S vVa

Windows Empty Project Crystal
Service Reparts..,

My Templates

A project For creating an application with & Windows user interface

Marne: MewPraoject

Diagram 4.2.3: New Project dialog box
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Whenever a new project is created and there is no pre-created solution, Visual Studio 2005
creates one and the project is held inside this solution.

Select Windows Application available under Templates as shown in the diagram 4.2.3.

REMINDER

% A Windows Application has a Graphical User Interface, which is often referred to
as GUI. A Windows Application is an application, which is displayed in a window.
Some of the examples of Windows Applications are Notepad, Microsoft Word and
SO on.

By default, all Windows projects created are hamed WindowsApplication along with a
running number as shown in diagram 4.2.1. This can be changed if desired. Once done, click

OK.

The IDE after a project is created, is as shown in the diagram 4.3.

W NewProject - Microsoft Visual Studio g@
File Edit View Project Buld Debug Data Tools Window Community Help
HE R WAt R ™ W= e e AR S - P B |
)3‘ | Form1.vb [Design]| Start Page - 3 || Solution Explorer -~ 1 %
2| 25 FFEES
5 o | ¢ _\g NewProject
=4 My Project

.;j?Sqution Explorer :_j:-a:? Sources
Properties T |

Form1.vb File Properties -

Z LY
Build Action Compile
Copy to Quitput Do not copy
Custom Tool
Custom Toal Nar
File Name Forml.vb

| Build Action
How the file relates to the build and
deployment processes.

Ready

Diagram 4.3: The IDE after project creation

Working With Solution Explorer

The Solution Explorer is used to manage the projects that make up a solution and the files
that make up each project as shown in diagram 4.4.1

VISUAL BASIC 2005 FOR BEGINNERS



Page 72

Solution Explorer - 0
2| WindowsApplication1

=d| My Project
=] Form1.vb

..:gs-:lutinn Explorer -__:J—:IDaia Sources

Diagram 4.4.1: The Solution Explorer window

When a file is double-clicked in the Solution Explorer, the file opens in Form Designer view.
Using Solution Explorer, working on multiple files is also possible. The Solution Explorer also
enables working with files known as miscellaneous files, which are not a part of any project.

Using Solution Explorer files can be opened, managed, added and removed. A context menu
appears when a file inside the solution explorer is right clicked. The context menu contains
options, which can perform various operations such as copying, cutting, deleting and so on.
Additionally, it also allows removing an item from a project by selecting the Exclude From
Project option from the context menu.

The options in the context menu vary depending on the object selected. For example, the
options that appear in the context menu for a form are different from the options that appear
for other items.

To change the name of an object using Solution Explorer, right click an object and select
Rename option from the context menu as shown in diagram 4.4.2. Rename the object and
press Enter as shown in diagrams 4.4.3 and 4.4.4.

Solution Explorer -~ 0 X Solution Explorer > 0 X
.2l WindowsApplicationi 2= WindowsApplicationl
=d| My Project =d| My Project
B e
3| open
Open With... n_';ﬂ Solution Explorer __ija:-:—. Sources
[=]| view Code Diagram 4.4.3: Renaming the form
j Wiew Designer
f;t View Class Diagram ”SO|L.IﬁOI'I Explorer - ];|_ x
Exclude From Project : o ] LR
xclude From Projec _]l Jj ﬂ d j 3-'{
daj Cut % WindowsApplication1
58] Copy =d| My Project
¥ Delete =] FirstForm.vb
] soluti | |
T Rename
Propertiel = | properties ._anIutinn Explorer J:_I}; Sources

Diagram 4.4.2: Context Menu Diagram 4.4.4: The form renamed
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Working With The Properties Window

The Properties window is used when the appearance or the operation performed by a form or
a control needs to be changed. If any particular control such as button on a form or the form
itself is selected, the Properties window is populated with the respective object's properties.
For example, double click a form to have its properties populated in the Properties window as
shown in diagram 4.5.1.

Properties >~ 1 X Properties > 1 X
Forml System.Windows,Forms.Form Form1 System.Windows.Forms.Form
= | = | | # |
Padding 0,0,0,0 Rad BackColor [ ] ButtonFac|#
RightToLeft Mo Backgrnundlma;D (none)
RightTolLeftLayo False Backoroundimac Tile
ShowIcon True I CancelButton  (none) » I
ShowInTaskbar True Cansdevaldauar True
Size 300, 300 ContgtMenuStr {none)
SizeGripStyle  Auto ContrplBox True
StartPosiion  WindowsDefaultls, Curs Default
Tag DoubleBuffered False
Text Form1 Enabfed True
TopMost False [ Fan Microsoft Sans Sel™ |
Text CancelButton
The text assodated with the contral, The cancel button of the form. If this
property is set, the button is 'dicked’ ...

Diagram 4.5.1: The Properties Diagram 4.5.2: The description
window of every property

The Properties window, allows editing the properties of the object selected.

The properties displayed in the Properties window are different for different objects i.e. the
properties of a button will differ from the properties of a form.

The Properties window displays a toolbar right after the objects name. This toolbar holds the
following buttons:

m} (Categorized) - It groups the properties of a control based on categories. For

example, when a button is selected and the = is clicked, the properties of the button
control are grouped into categories such as Appearance, Data, Layout and so on
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Properties ~ a1 x

FirstForm System,Windows,Forms.Form =
A B

i+ = £l | s =

El Accessibility ~
AccessibleDescripti [

AccessibleName

AccessibleRole Default

Appearance

Behavior

Data

(ApplicationSetting

(DataBindings)

Tag

El Design =]

Behavior

HEOBREBRA

Diagram 4.5.2.1: Properties grouped on categories
m} A (Alphabetical) - It arranges the properties alphabetically

o & (Properties) - It shows a list of properties for a particular form or controls as shown in
diagram 4.5.2

a & (Events) - It shows a list of events for a particular form or controls as shown in
diagram 4.5.3

Properties - 0 x

Forml System.Windows.Forms.Farm -

ImeModeChange e
Inputi anguageC

InputLanguageC

KeyDown

KeyPress

Keyllp

Layout

Leave

Load Forml_Loa |¥|
LocationChange

MaxirnizedBound %)
Load

Occurs whenever the user loads the
form,

Diagram 4.5.3: The events
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m} (Property Pages) - It displays the Property pages dialog box for the selected
component. It can be used for viewing and editing properties related to the configuration
of the project

The Properties window for each form or control has two sections i.e. the name of the
property and the value of the property.

Properties > 1 X

FirstForm System.Windows.Forms.F =

=51 1[=] # |

(ApplicationSett A
(DataBindings) :ﬂ_ E m pty
(Name) FirstForm Field
Property —b—IAcceptButton I (none)
MName ArcessibleDescri

AccessibleMame
AccessibleRole  Default

AllowDrop False
AutoScaleMade Property
Autoscrall False Value
AutoScrollMargir @, 0 B
Text

The text assodated with the contral,

Diagram 4.5.3: Sections in Properties windows

The name of a property appears in the left column. The names of properties are always one
word. This same name can be used to access the property via code.

The box on the right hand side of each property name represents the value held inside that
property. This can be set using this window.

The different fields available in the Properties windows are:

0 Empty Fields - By default, the empty fields have nothing in their properties as shown in
diagram 4.5.3. Most of these properties are dependent on other settings of the program.
For example, a menu property for a form can be set only after creating a menu. To set
the property value for such a field, just type the property value or select it from a list if
one exists

0 Text Fields - There are fields that expect the developer to type a value as shown in
diagram 4.5.4. Most of these fields have a default value. To change the value of the
property, click the name of the property, type the desired value and press Enter. While
some properties, such as the Text, would allow anything, some other fields expect a
specific type of text such as a numeric value
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Froperties =4 x|

FirstForm System.Windows.Forms.F =

[24]]

RightToLeftLayao False Fadl

ShowIcon True
ShowInTaskbar True

Size 329, 277
SizeGripStyle Auto
StartPosition WindowsDefaultLe
Tag

Text Text
TopMost False ' Field
Transparencyke |:| e
Use\WaitCursor  False

Text
The text associated with the contral,

(e

Diagram 4.5.4: Text field

0 Expandable Fields - Some fields have a + (plus) sign, which indicate that property has
a set of sub properties that actually belong to the same property and are set together. To
expand such a field, click the + (plus) sign and a - (minus) sign will appear as shown in
diagram 4.5.5.1 and 4.5.5.2

Froperties - 31 X Properties - 1 X

FirstForm System,Windows,Forms.F = FirstForm System,\Windows,Forms.F =

RightTolLeftLayo False [ RightTolLeftLayo False Rl
Showlcon True Shaowlcan True
ShowInTaskbar True

| Size 329, 277 | 329, 277

SizeGripStyle  Auto Width 329
StartPasition WindowsDefaultL: Height 277
Tag SIZEGIPoLYE AU
Text Form1 StartPosition WindowsDefaultLc
TopMost False [ Tag E
Transparencyke |:| = Text Form1 i
UseWaitCursor False ] TopMost _False ]

Text Size

The text associated with the contral, The size of the control in pixels,

Diagram 4.5.5.1: Clicking + sign Diagram 4.5.5.2: Field Expanded

Some of the properties are numeric such as Size as shown in diagram 4.5.5.1. With such a
property, click its name and type two numeric values separated by a comma.
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Some other properties hold an enumerator or a class. If such a field is expanded, it will
display various options. For example, with Font property, selection can be made from a list.

Froperties » 1 X

FirstForm System,Windows . Forms.F =

True i)
Microsoft Sans..]
[&h] Microsaft sa
8.25

Paint

False

GdiCharset 0

GdiVerticalFor False

Italic False

Strikeout Falze

Underline False Il
Font

The font used to display text in the
control,

Diagram 4.5.6: Font property expanded

0 Boolean Fields - Some fields can have only Boolean values i.e. either True or False
value. To change their setting, either select from the combo box or double-click the
property to toggle to the other value

Froperties v Al 5

FirstForm System, Windows.Forms.F =

{DataBindings)
{Mame)
AcceptButton
AccessibleDescr

FirstForm
(none)

AccessibleMame
AccessibleRole  Default

AllowDrop | False ! <

{ApplicationSett |

Properties

=

Font
FareColor

HelpButton
Icon

ImeMode

IsMdiContainer

Boolean KeyPreview

AutoScaleMode Font
AutoScrall False

(Mame)

Indicates the name used in code to
identify the object.

AutoScrollMargir 0, 0 ]

Field

Language
Localizable
Location

Icon

v 1 X

| FirstForm System,Windows.Forms.F »

Microsoft Sans Se|# |

Il controText

FormBaorderStyle Sizable

Falze

False
(Default)
False

0,0 s

Indicates the icon for a form. This icon
is displayed in the form's system men...

Action
Field

Diagram 4.5.7: Boolean field

Diagram 4.5.8: Action Field

0 Action Fields - Some fields would require a value or item that needs to be set through
an intermediary action. Such fields display an ellipsis button. When this button is clicked,
a dialog box pops up and the value can be set using this dialog box
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o Selection Fields - The value of some fields can be changed using a drop down list box
as well. This drop down list box will display a list of property values that can be set as
shown in diagram 4.5.9

Properties >~ 1 X

FirstForm System.Windows.Forms.F =

RightToLeftLayo False [Ead)

ShowIcon True

ShowInTaskbar True
Size 329, 277

;. i, -+, A4
StartPosition  efaultLocation| ] e Selection
TqManual Field
TqCenterScreen
T{WindowsDefaultLocation
TiWindowsDefaultBounds
u{CenterParent kd

Determines the position of a form when
it first appears.

Diagram 4.5.9: Selection Field

There are various types of selection fields. Some of them display just two items. To change
their value, just double-click the field to toggle between the two values. Some other fields
have more than two values in the field. To change them, just click the adjoining arrow and
select the desired value from the list or double-click the property name a few times until the
desired value is selected.

It is a good programming practice to change the name of the form in the title bar i.e.
(“ﬂ“’”‘“ | =0 select the Text Form1 property from

the Properties window and rename Form1 to the appropriate form name as shown in diagram
4.,5.10. Press Enter and the name changes according to the new name entered.

. Forml.vh[Design]’_ Start Page |

o' First Form I E]@

Properties > 1 X

Form1 System.Windows.Forms.Form ~

= [U[=]
Padding 0,0,0,0 ]
RightToLeft Mo
RightToLeftLaya False
ShowIcon True
ShowInTaskbar True
Size 300, 300
SizeGripStyle Auto
StartPosition WindowsDefaulti s
Tag =
Text FirstForm |
TopMost False i
i

The text associated with the control,

7
F ‘_ ]

Diagram 4.5.10: The name in the title bar changed
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Working With ToolBox

The Toolbox contains various tools and controls available in Visual Basic 2005. To open the
Toolbox, move the mouse pointer on the Toolbox tab displayed on the left margin of the IDE.
Alternatively, open the Toolbox by selecting the Toolbox command from the View menu.

By default, the Toolbox displays only the General tab. However, the Toolbox displays
additional tools depending on the currently opened designer or editor. To view all the tools in
a particular tab in the Toolbar, click the + (plus) sign available on the left of each tab in the
Toolbox.

" NewProject - Microsoft Visual Studio =<
Fle Edit View Project Buld Debug Data Format Tools Window Commurity Help

Bk N=AERN N N =Y Lol Z=[E o | st pd Se
S| Toobox -= X ~ || Solution Explorer -1 X
= | [=_All Windows Forms [~ = |5 3| ELELA
g R Ponter B@ | NewProject

5 BackgroundWorker ] Bl My Project

¥ BindingNavigator = =] Form1.vb

21 BindingSource

Buttan

CheckBox

87 CheckeduistSox
[%] ColorDialog
B ComboBox

_uzlsmminn Exwplorer .j:a:a Sources
[ ContextMenuStrip .

‘ DataGridview Properties -1 x
o7 Dataset Form1 System.Windouws. Forms Form +
T DateTimePicker = |
[£5] DirectoryEntry Size 300, 300 -
1 DirectorySearcher SizeGripStyle  Auto
% DomainUpDown = StartPosition  WindowsDefaultis
@ ErrorProvider Tag
{8] Eventlog | Tent i Form1 v
5] Filesystemiwatcher | Text
= HouLayoutPane] The text assodiated with the control.
5| FodeEronsebab  vl|
Ready

Diagram 4.6.1.1: The Toolbar loaded with controls and items

Toolbox - = X
i+ All Windows Forms

+ Common Controls

| Containers

| Menus & Toolbars

Data

Components

| Printing

Dialogs

| Crystal Reports

[= General |

ol o

There are no usable contrals in this
group. Drag an item onto this text to
add it to the toolbox.

Diagram 4.6.1.2: The Toolbar tabs
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The following are some of the tabs (right at the bottom of the toolbox) available in the
Toolbox as shown in diagram 4.6.1.2:

0O General tab - By default, the General tab does not display any controls. However,
controls can be added such as custom controls to the General tab. Custom controls are

controls created by users or third-party vendors

i}
X

Toolbox -

= General

There are no usable controls in this
group. Drag an item onto this text to
add it to the toolbox.

Diagram 4.6.2: The General tab

0O Crystal Reports tab - It displays components such as CrystalReportViewer,
ReportDocument and so on, that can be used in Crystal Reports

Toolbox = X
| - Crystal Reports |
k Pointer
i:_‘-g CrystalReportViewer

\}j ReportDocument

Diagram 4.6.3: The Crystal Reports tab

0 Dialogs tab - It displays components such as ColorDialog, FontDialog and so on, that
can be used for Dialog boxes

Toolbox - = X
i.—' Dialogs |

k Pointer

%] ColorDialog

3] FolderBrowserDizlog

47 FontDialog

£| CpenFileDialog

ﬂ SaveFileDizlog

Diagram 4.6.4: The Dialogs tab

0 Printing tab - It displays components such as PrintDialog, PrintDocument and so on,
that are related to printing
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Toolbox - = X

['= Printing
k Pointer
ﬂ PageSetuplialog
_é PrintDizlog
_‘_3; PrintDocument

-—\-‘\. PrintPreviewControl

:ﬂ FrintPreviewDislog

Diagram 4.6.5: The Printing tab

0 Components tab - It displays components such as EventLog, MessageQueue and so on,
that can be added to Visual Basic 2005 projects

Toolbox - = X

[= components
k Pointer
5 Backaroundiorker
E_;—_I DirectoryEntry
{_fl Directory5earcher
&) ErrorProvider
i3] EventLog
6-;] FileSystemWatcher
HelpPraovider
sl ImageList
! MessageQueus
(4] PerformanceCounter

_j Process

4 SerialPort

¥

fﬁ! ServiceContraller

Timer

Diagram 4.6.6: The Components tab

0 Data tab - It provides data objects such as DataSet, DataGridView and so on, that can
be included in Visual Basic 2005 forms and components

Toolbox - = X

ke Pointer

29| Dataset

.J DataGridview
231 BindingSource
-‘_—‘" BindingMavigatar
\Z] Reportviewer

Diagram 4.6.7: The Data tab
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0 Menus & Toolbars tab - It provides components such as ContextMenuStrip, ToolStrip
and so on, which are the types of menus or toolbars to be included to Visual Basic 2005

projects

0 Containers tab - It provides

Toolbox

[= Menus & Toolbars

& Pointer

] ContextMenuStrip
= MenuStrip

| Statusstrip

i0w ToolStrip

71 ToolStripContainer

Diagram 4.6.8: The Menus & Toolbars tab

components such as Panel, TabControl and so on, which

are different types of layout for the look and feel of Visual Basic 2005 forms

Toolbox

- = X

[= Containers

k Fointer

&% FlowLayoutPanel

2 GroupBox

7] Panel

[1] splitContainer
TabContral

{o= TableLayoutPanel

Diagram 4.6.9: The Containers tab

0 Common Controls tab - It displays common controls that can be added to forms

Toolbaox

- = X

[=" common Controls

k Pointer

Button
CheckBox

[8% checkeduistBox
&5 ComboBox

T DateTimePicker
A Label

A Linkiabel

=2 ListBox

337 Listview

#-| MaskedTextBox
__“ MonthCalendar
] Notifylcon

1% NumericUpDown
Lﬂ PictureBox
@) ProgressBar
(& RadioButton
25 RichTextBox
[abl] TextBox

lkﬂ ToolTip

T Treeliew

[5g WebBrowser

Diagram 4.6.10: The Common Controls tab
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o All Windows Forms tab - It provides all the components available in the tabs Common
Controls, Dialogs, Printing, Data, Components, Containers, Crystal Reports and Menus &

Toolbars
TDD|bD)f - = X
[= All Windows Forms |t |
ke Pointer

5 BackgroundWorker
-‘“—" BindingMavigator
iij BindingSource
Button

CheckBox

B< CheckedlistBox

j ColorDialog

=3 ComboBox

FE| ContextMenuStrip
'+ DataGridview

=% Dataset
T DateTimePicker

£| DirectoryEntry

{21 DirectorySearcher
& DomainUpDown
&l ErrorProvider
i3] Eventlog
@ FileSystemWatcher
== FlowLayoutPansl
j FolderBrowserDialog
ﬁ FontDialog

" GroupBox
HelpPraovider

93 HScraollBar
=M Imagelist

A Label

A LinkLabel

= ListBox

2% Listview —

Diagram 4.6.11: The All Windows Forms tab

There are three ways to add controls to the form:

0 Click once on any control that is to be added to the form. The mouse pointer changes to
represent a button and now click once on the form. The button is added to the form.
Refer to diagrams 4.7.1 and 4.7.2
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>F| Misohes 28| FirstForm.vb [Design]* | StartPage

= || = All Windows Forms | ; )

:: = Common Controls ;

i & Pointar = 5 First Form g@
| Button |
CheckBox

85 CheckedlistBox

=% ComboBox ]
T DateTimePicker
A Label

A LinkLabel

=3 ListBox

237 ListView

#_| MaskedTextBox
7] MonthcCalendar

=] NotifyIcon

1% MumericUpDown
|8 PictureBox

[T} ProgressBar

(%) RadioButton
25 RichTextRox
abl TextBox ]

Diagram 4.7.1: Single clicking Control Diagram 4.7.2: The button added

0 The other way is the drag and drop method to add the controls to the form. Refer to
diagrams 4.7.3 and 4.7.4. Here the mouse pointer represents the combobox

| Toobox > =X “FirstForm.vb [Design]* | StartPage

é # All Windows Forms [

= || = Common Controls ™

= I Pointer o' First Form g@
Button

ChedkBox

g, CheckedListBox .

|'::? ComboBox

7 DateTimePicker TE . .
A Label | [
A LinkLabel 3

=. ListBox

sa Listview

#-| MaskedTextBox
m MonthCalendar
=] Motifylcon

1% NumericUpDown
,_'ﬂ PictureBox

@) ProgressBar
(%) RadioButton

Diagram 4.7.3: Dragging and dropping Diagram 4.7.4: The combobox added
Control

jul
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0 Double clicking a control is the third way of adding a control to a form. Here the mouse
pointer does not change instead the control is immediately added to the form. The
control gets added at the top left corner just below the title bar as shown in diagrams
4.7.5 and 4.7.6

Toolbox v = X ; “FirstForm.vb [Desién] 'Sta-rt'Page |
+ All Windows Forms sl

=/ Common Controls i PES T
b Pointer =

Button
CheckBox

B checkeduistBox

=5 ComboBox

E . | |
. b s

I|| A Label, | :
A LinkLi.\\%

= ListBox

22" ListView

#-| MaskedTextBox
-" MonthCalendar
=] Notifylcon

1% NumericUpDaown
i;ﬂ PictureBox

Diagram 4.7.5: Double clicking Control  Diagram 4.7.6: The Label added

Naming Conventions

By default Visual Basic 2005 IDE names the controls. For example, Labell for the first Label
control, Button2 for the second Button control, and so on. Each name should be changed and
prefixed with a short identifier describing the type of control it is. This makes it much easier
to understand what type of control is being dealt with when the code is referenced later.

For example, there is a control called Name, without a prefix of Ibl or txt, the developer
would not know whether it is a textbox or label with that nhame.

When multiple developers work together on a particular project, it is very important to keep
the coding style consistent. One of the most commonly used styles used for naming controls
within an application is the Modified Hungarian notation.

The notion of prefixing control names to identify their use was brought forth by Dr. Charles
Simonyi. He worked for the Xerox Palo Alto Research Center (XPARC), before joining
Microsoft. He came up with short prefix mnemonics that allowed developers to easily identify
the type of information a variable might contain.
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Since Dr. Simonyi is Hungarian and the prefixes make the names look a little foreign, the
name Hungarian Notation stuck. Since the original notation was used in C/C++ development,
the notation for Visual Basic 2005 is termed Modified.

Some of the prefixes, which can be used in Visual Basic 2005 are as follows:

Control Prefix Example
Button btn btnName
ComboBox cmb / cbo cmbProfession
CheckBox chk chkSelect
Label Ibl IblState
RadioButton rb / rdb rbSingle
TextBox txt txtCountry
PictureBox pic picPersonel
Grid grd grdData

Hungarian Notation can be a real time-saver when looking at code written by someone else
or at the code written several months ago. However, the most important thing is, to be
consistent in the naming. When starting with coding, pick a convention for naming. It is
recommended that the de facto standard, Modified-Hungarian, is used for Visual Basic 2005,
but it is not mandatory.

Once a convention is picked, stick to it. When modifying someone else's code, use theirs.
There is very little code that is ever written, put into production and then forgotten. A
standard naming convention followed throughout a project will save countless hours when
the application requires maintenance later.

Designing The Form

If the double click method is used to add a control, then the control is situated at top left
control of the form or if the drag and drop method is used, then the control is placed
accordingly at the place appointed.

In either way, the control can be repositioned. To position the control, place the mouse
pointer over the control to be repositioned. The mouse pointer changes its shape to that of
four arrows as shown in diagram 4.8.1.

Then click on the left mouse button and drag the control to another location and release the
left mouse button after the desired position is selected.
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oz First Form

BEx

] [ Cancel ]

Diagram 4.8.1: Changing the position of a control
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When a TextBox control is dropped or selected/clicked on the form a black arrow can be seen
on the top right side of the text. When this arrow is clicked, Visual Basic 2005 shows the
option of multiple lines. If multiple lines are needed, then tick the checkbox available next to

it.

FirstForm.vb [Design] |

A TextBox Tasks
=== ] MultiLine

[ Cancel ]

Diagram 4.8.2: The option of multiple lines

These options differ for different controls. For example, when a RichTextBox control is

dropped then its options are Edit Text Lines and Dock In Parent Container.

Diagram 4.8.3 shows the labels, textboxes and buttons in a very crude manner. That is they
are not in one line or not adjusted according to their counterparts. The label Name is
somewhere while its counterpart textbox is somewhere else.
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Visual Basic 2005 IDE has a new feature to adjust controls with respect to each other in

forms.

For example, to bring the Name label and its textbox in one line click on any of the control
and accordingly adjust the control by dragging it in a direction as desired as shown in
diagrams 4.8.4 and 4.8.5.

_~FirstForm.vb [Design]* | Start Page |

o' First Form g@
Name
Address
o=
pre—
ul

Diagram 4.8.3: Controls in a crude manner

FirstForm.vb [Design]* | Start Page

a5 First Form

Address

Save

Mame | S: |

~FirstForm.vb [Design]* | Start Page
o | | (e SE
MName I I~ I
b
Address
e —
—

Diagram 4.8.4: Double clicking Control

While dragging the control, the blue line indicates that the base of the textbox control is
exactly inline with the base of the label control where as the purple line indicates that text

Diagram 4.8.5: The Label added

box control is exactly horizontally centered inline with the label control.
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The diagram 4.8.6 shows two blue lines and a purple line. Two blue lines indicate that the
text box of Address is vertically inline with the textbox of Name from both sides. A purple line
indicates that text box control is exactly horizontally centered inline with the Address label
control.

~FirstForm.vb [Design]* | Start Page

s First Form E]@

Name

Address

%7

Cancel
Save

Diagram 4.8.6: Multiple lines while adjusting controls

Resizing a form or a control is also possible. For that select a form or any control whose size
has to be resized. Keep the mouse pointer to any small round spot, which can be seen on the
borders. The mouse pointer changes, now drag and change the size of the form or controls
as desired as shown in diagrams 4.8.7 and 4.8.8.

| FirstForm.vb [Design]* “FirstForm.vb [Design]* |

o' First Form g@
t 1" First Form g@

Name

Address

Name
Address
[ Save l [ Cancel l

2 ;

Diagram 4.8.7: Mouse pointer changed = Diagram 4.8.8: Dragging the mouse
pointer

If a shortcut key or a hot key has to be created for a button, add an ampersand (&) in the
Text property of that button. The letter with the & sign placed in front of it will become
underlined as shown in diagram 4.8.9. This indicates to users that they can use Alt + Letter
key combination.
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“FirstForm.vb " FirstForm.vb [’Des’irgn]'r

a5 First Form g@@

Name .I.:;ropertiés -~ I x|

btnSave System.Windows.Forms.Button =

=[ELz e
CPatEi T o Modifiers Friend |~
C[ Save }3 [ Cancel ] Padding 0,0,0,0
= = RightToleft Mo
\ Size 75, 23

TablIndex 4

TabStop True —

Taq L=

Text &Save I —
|

TactAlion Tid el antar

| Text
The text associated with the control.

Diagram 4.8.9: Creating Shortcut key

Pressing Alt + S would be the same as clicking the Save button as shown in diagram 4.8.9.
There is no need to write code to make a shortcut key.

WARNING

. Sometimes when the form is run, the underline may not appear unless and until
the Alt key is pressed.

Short Description Of ToolBar

Many toolbars are available within the Visual Studio 2005 IDE such as Formatting, Help, Style
Sheet, Layout and so on. Each of these toolbars can be added to or removed from the IDE
using View > Toolbars menu item.

When a new project is selected, by default the standard toolbar appears. The standard
toolbar includes standard window toolbar buttons such as Open, Cut, Copy, Paste and so on.
On the right hand side of the standard toolbar, there are several buttons that call other
windows in the IDE. Additional toolbars dynamically appear depending on the function
performed.

New Project/ ' | Commenting, | Step In/
Web Site | m Uncommeting O\mrp;r Out
-4 ﬂl

claleslo- el o ke sla s aall
r 3

Y
Open File Undo, Redo T
|Cut, Copy, Pastel Additional Toolbars
|Dehugging I appearing dynamically
| Adding New Iteml

Diagram 4.9: Standard Toolbar

4. GETTING STARTED WITH THE IDE



Page 91

- NN R~ N~ provide access to creating new project or web site, open the
commonly used projects, adding new items and saving new project or the existing project.

& =3 04 are used for editing i.e. cut, copy and paste.

S allows finding text in the code throughout the code or project.

—
= = allow commenting and uncommenting code. B s for undoing and redoing
edits.

Il & provides the ability to run the form, pause the execution at runtime and terminate
its execution.

= are icons to step in or step out or step over code at runtime for debugging.

Lastly 53 Wi Wi B o provides quick links to the Solution Explorer window,
Properties window, Object Browser, Toolbox, Error List, Command window and many other
windows. The other window's icons appear as the work on the project progresses.

Saving The Project

To save the project, select File > Save All. Save Project dialog box appears as shown in
diagram 4.10.1.

Save Project @

Mame: PMS|
Location: . 1:\Project .:.v
Solution Mame: SCT_Projects Create directory for solution

[ Save ][ Cancel ]

Diagram 4.10.1: Save Project dialog box

This dialog box displays the name of the project entered earlier while creating a new project.
The Solution Name by default is assigned the same name as that of the project only if it was
not saved earlier using a different name.

By default the Location i.e. the path where the project is located will be C:\Documents and
Settings\<Name>\My Documents\Visual Studio 2005\Projects\. To change the

current path click | &= | available next to Location text box and select the desired path
for saving the project.
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After saving, the directory structure that holds the project saved will look as shown in
diagram 4.10.2.1 and 4.10.2.2.

Faolders b4 Mame
= |2 Project Y .,;!F‘MS

= ) SCT_Projects J,,%SCF_F‘rDjecis.sln

+ ) PMS SCT_Projects.suo

Diagram 4.10.2.1: Directory Structure of the project saved

Folders g _Name
=l I3 Project B C2bin
5 [5) SCT_Projects LMy Project
= i
& _|I:||n 18] EmployeeMaster. Designer.vb
C3) My Project EmployeeMaster.resx

18] EmployeeMaster.vb
x'ﬂ“ﬂ PMS. vbproj

Diagram 4.10.2.2: Directory Structure of the project saved

+ :;I l:ll:l_'l

The following is the directory structure:
o J:\Project is parent directory that holds the solution named SCT_Projects

o SCT_Projects is the main solution directory where all the projects are in form of
directories. This directory holds two files and one directory named PMS:

The Files:
e SCT_Projects with the extension Microsoft Visual Studio Solution (.sIn) is the
solution file that stores the metadata to define the solution

e SCT_Projects with the extension Microsoft Visual Studio User Options (.suo)
holds the metadata and properties to customize the IDE

The Project Directory:
e PMS is the project directory where all the forms are saved along with project
files, designer files and so on

= EmployeeMaster.vb is the file, which holds the code written for that
particular form. If the file EmployeeMaster.vb is opened then only the code
held inside that file will be displayed

= EmployeeMaster.Designer.vb is the file generated by the IDE. There are
designer files for every form created. This file holds the actual form design
layout

= EmployeeMaster.resx is the .NET resource file which stores information
about various resources used in the project
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= PMS.vbproj is the project's main file that stores the metadata to define the
project

= The bin directory holds all the runtime executables

= The My Project directory holds project related files that define and hold
assembly information, settings related to that project and resource files

= The obj directory holds any assemblies created as a result of adding a COM
reference to the project

If any changes are made either in the code editor or in form design, Visual Basic 2005
displays an indication of the changes made and not saved in the tabbed window. It displays *

(asterix) as an indication. Once the project is saved using Ctrl + S or clicking H, this
indication will be removed.

; I FirstForm.vb [Design]* | I

o5 First Form

BT

Name

Address

“FirstForm.vb [Design] I}

a2 First Form

METx

Name

Address

Save ] [ Cancel = ] ’ =

]

=}

Diagram 4.10.4: Asterix (*) removed
after the project is saved

Diagram 4.10.3: Asterix (*)
indication for saved project

Opening The Existing Project
Projects that already exist can be opened using one of the following ways:

Using Start Page

The Start Page provides a section as shown in diagram 4.10.5.1 that lists the most recent
projects, select the desired project from the list to open.
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Microsoft:

T
&

Recent Projects
ElpMs
FirstProject

e Mathematics
\I‘.:"E StringFunctions

Open: Project...  |Web Site...
Create: Project...  |web Site...
! y

Visual Studio 2005

MSDN: Visual Basic

Adding Blogging to Your Apps with My.Blogs and Visual Basi

Fri, 27 Jan 2006 05:56:02 GMT - My.Blogs is a collection of sample co
to easily provide programmatic access to blogs in your applications. g
how easy it is to read and publish blog entries within Visual Basic 200
Visual Basic: Navigate The .NET Framework And Your Projed
Tue, 24 Jan 2006 18:58:48 GMT - One of the biggest issues that pro
is the sheer breadth of .NET, which can make finding the best class fj
quite daunting. Duncan Mackenzie shows how the My namespace in
will make your life easier.

Converting a Data-Oriented Application from Visual Basic 6

Tue, 24 Jan 2006 18:24:04 GMT - Ken Getz and Paul Sheriff show yo

Diagram 4.10.5.1: Recent Projects

The Start Page also provides ©Pen:

Project...

Open Project dialog box as shown in diagram 4.10.5.2.

"Open Project

2

Look in: ||E] Projects t] @ | Q X Cu E - ook~
@ 15 vsMacrasan
Desktop
el
My Projects
My Computer
File name: || M () Add to Solution e
(#) Close Solution
Files of type: | Project Files (*.sln; ™. dsw; * vow; *, vl

Diagram 4.10.5.2: Open Project dialog box
Using this dialog box locate the desired project and click .
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Using Menu Item

To open a project using a menu item, select File > Open Project or use Ctrl + O.

W Start Page - Microsoft Visual Studio

m Edit Wiew Tools Window Community Help

5| New Project... Cirl+N ’ Fel -=a _I =
[4 | MNew Web Site...

|51 Open Project... cirl+0

15: Open Web Site. ..

5 OpenFile...

Close
_. Close Project
il Sa=ve Solarted Thame  Cirlac

Diagram 4.10.5.3: Opening a project using Menu |tems

This will display the Open Project dialog box as shown in diagram 4.10.5.2. Using this
dialog box locate the desired project and click

Using The Toolbar

To open a project using a toolbar, click ﬁ.

File Edit Wew Tools Window Community Help

= Eﬂgl & =3 ;11['

Diagram 4.10.5.3: Opening a project using Toolbar

This will display the Open Project dialog box as shown in diagram 4.10.5.2. Using this
dialog box locate the desired project and click

Alternatively, use Windows Explorer, locate the desired project and double click the .sln file

to open a solution that holds the project or double click the .vbproj file to directly open the
project.
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Using The Code Editor

The Code Editor window allows creating and editing Visual Basic 2005 source code. After
designing the user interface for the project by placing controls on the form, switch to the
Code Editor to develop the Visual Basic code spec that makes the forms and their controls

functional.

The easiest way to call up the Code Editor is to double-click a form or a control. Then, begin
typing the statements that will be executed when the user performs the most common action

on that control.

Another way to call up the Code Editor is to click =1 available in the Solution Explorer.

" NewProject - Microsoft Visual Studio

File Edit View
HERR W= R - NI REETE: W NE WA=t I I

Project Build Debug Data Tools Window

ST
Community  Help

n: AR R e N Y |

¥ b | FormL.vb [Design]

|+ | | (Declarations)

~ | |Solution Explorer -4 x
v i BlsElEES
—1| 22 NewProject
~
4 E ject

Code Editor window

E)solution Explorer |lData Sources

Properties |

=[BT

v
>

n7 Col 1 Chi NS

Diagram 4.11.1: Code Editor Window

If a form is double clicked then the procedure with the form name appears in code editor
window held inside the class declaration. The procedure is a part of that class.

The Code Editor works much like other text editors. However, the Code Editor has a number
of special features that simplify the task of editing / writing Visual Basic code:

0 Color - Color is used to distinguish Visual Basic 2005 keywords from variables, comments
and other language elements. And also many types of coding errors are automatically
highlighted as they are typed so they can be corrected or rectified

4. GETTING STARTED WITH THE IDE



Page 97

 NewProject - Microsoft Visual Studio M=%
Fle Edit View Project Buld Debug Data Took Window Community Help

T N T N DR VIV RN AR S e e Joc b R B |

% Formivb| Formivh [Design] | ] ~ 3 || Solution Explorer R
g J#Buttont [se] [ # e vl L2l & FLE S

g i 2| NewProject

=dl My Project

5] Form1.wb

il Solution Explorer [F]Data Saurces

Properties -3 x

Button1_Click Attributes

1. Colors used to distinguish variables, Il | E
comments, keywords

2. Errors highlighted for correction

[v
“ L ’.
Ttem(s) Saved Lng Col 5 cho NS

Diagram 4.11.2: Colors for distinguishing keywords and errors highlighting

0 IntelliSense - This feature pops up a drop down list automatically and guides the
developer by showing what methods / properties / data types and so on are available for
a given object. As the keywords are typed letter by letter it reaches the matching word.
For example, if String is the word to be typed, just type Str and IntelliSense will
automatically highlight that keyword into its list and also display the details of that
keyword as a tool tip. Either select this keyword by pressing Enter or type the entire
keyword

“¢ StringComparer

=P StringComparison

=@ StringDigitSubstitute

“#¢ StringFormat v

Commarn All

[

= Click (B¥yVal sender As System.C|

‘j 4 StatusBarPanelClickEventHandler | !

“End Class =7 StatusBarPanelStyle -_'i]SOIutiDn Explorer )j:-a:a Sources
“¢ StatusStrip -

; : a
“i§ Stopwatch Froperis = =
=iString String T
InteIIiSenser—D <A StringAlignment Represents text as 3 series of Unicode characters,
e AT =]

Diagram 4.11.3: IntelliSense

0 Parameter Information - Parameter Information displays the parameters that a
procedure, function, method or property accepts. If a function is used in the source code
named MessageBox.Show, after the function name is typed into the code editor window
and as soon as a left parenthesis is typed to begin describing parameters, Visual Basic
2005 automatically shows the correct parameters along with data types and overloaded
versions of that functions if any (represented in this case as 1 of 21 that shows that
MessageBox.Show function has 21 overloaded versions)
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aptions As System.Windows Forms. MessageBoxOptions, displayHelpButton As Boolean)
As System.Windows.Forms.DislogResult
text: The text to display in the message box.

JTJ y¥Val sender As System.Cbject, ByVal & As S5y
E5l50lution Explorer |[F7]Dats|
L T & 1of 215 Show (text As String, caption As String, buttons As System,Windows.Forms,MessageBoxButtons,
End Clas| icon As System, Windows.Forms,MessageBoxIcon, defaultButton As System.Windows, Forms, MessageBoxDefaultButton,

[Parameter Information|

Diagram 4.11.4: Parameter Information

0 Description of an Error - To see the description of an error, move the mouse pointer

over the error (represented as a curly blue line)

= Friwvate Sub Buttaon ¥vWal sender hs Syst
Dim Sew 28 Description of
oFE “E=s an error
MeszzsageBox . S5t

i

- End Sub

Mame 'Strl' is not declared.

LEnd Class

Diagram 4.11.5: Description of an error

Detection Of Wrong / Outdated Syntax - If the syntax is wrongly written or belongs

to some previous version which Visual Basic 2005 does not support then Visual Basic
2005 IDE underlines the error with an exclamation mark as shown in diagram 4.11.6.1.
Here Type...End Type syntax has been replaced by the Structure...End Structure
syntax. When the mouse pointer is moved over the underlined word it displays an

exclamation mark as shown in diagram 4.11.6.1

~Formlvb | Forml.vb [Cesign] |

éll](General) “V',g{lj(Declarations)

H Public Class Forml

[Type' statements are no longer supported; use 'Structure’ statements instead. |

BRI

;‘{-‘ce Project

End Type

%

LEnd Class

Diagram 4.11.6.1: Warning sign and a short description of error

If the mouse pointer is moved over the warning sign a down arrow appears. Click once
on the arrow and a description of syntax appears that informs that the Type syntax is no
longer supported use Structure syntax instead as shown in diagram 4.11.6.2
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'Structure’ statements instead.

— 1 & | Replace Type' with 'Structure’,

~Form1lwb| Forml.vb [Design] [ - X

J_J (General) ™ |iZ] (Declarations) v

E Public Class Forml “;‘
Type Project
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Puklic Class Forml
Fubklic Class Porml

|E=na Llass

Expand All Previews

Diagram 4.11.6.2: Long description of a syntax error

0 Indentation - If the code is not indented while it is being typed Visual Basic 2005 Code

Editor will automatically indent the code

=2 Private 5ub Buttonl Cli
Dim 5tr As String
End Sub
LEnd Class

ick (ByVal sender &s System.Object

No indentation

Diagram 4.11.7.1: Cod

Press enter and the indentation is done.

e written without indentation

FJ—] Frivate Sub Buttonl Click(ByVal sender As 5y
‘ Dim Str As String
r Bad. Sub |Automatic identation|

End Class

Diagram 4.11.7.2: Visual Basic

2005 automatically indented the code

o Collapse Region - One great feature of the code editor is the ability to collapse regions
of code so that only the header can be seen. There is a & (plus sign) next to every

method/function/class and clicking on

them would expand the region and the sign

changes to [Z/ (minus). Three dots appear near the header whose region is collapsed. If
this feature needs to be turned off then select Edit > Outlining > Stop Outlining
menu item. If this feature is needed (if it was switched off earlier) then select Edit >
Outlining > Collapse to Definitions menu item
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_-"Forml.vb: ‘Farm1.vb [Design] 7_ B - X
Vfg Form1 .:.v. '.sz(Declarationsj "v.:'
O Public Class Forml 7.|
&3] |E:'_'-.rrs.-:e Sub Forml Load .. | =
Collapse Region
o] [Private Sub Burtoni Click ...

Click(BvVal sender ALs System.Cbject, ByWVal e As 5y

Diagram 4.11.8: Collapse Region

0 Code Snippets - Visual Studio now provides segments of sample code ready to insert
into a Visual Basic project. To display a list of available code snippets, right-click the
active document in the Code Editor and select Insert Snippet from the context menu.
Select the name of the snippet needed, the code is inserted into the editor and then it

can be modified as desired

To manage the folders in which code snippets are stored and to add new snippets, select

Code Snippet Manager from the Tools menu

~FirstForm.vb |~ FirstForm.vb [Design] | ] “FirstForm.vb |~ FirstForm.vb [Design] |
P FrsIform L | ¥ FirstForm w | |
In Sy=tem 72 . Forms . Form
oP aaT ¥ rts System.Windows.Forms.Form
L -1 Public Class FirstForm
E Micw Besioncs L Insert Snippet:
_|"-_EL Insert Snippet... End Clasfinnication - Compiing, Resources, and Setings | # |
28 Go To Definition [ Collections and Arrays |
ﬁ [ Common Code Patterns
el O NN [ Connectivity and Networking
*=| Run To Cursor [ Crystal Reports
& cut [ Data - Designer features and ADO.MNET
- [ Data Types - defined by visual Basic
53 copy o : SE :
[ File system - Processing Drives, Folders, and Files
.ﬂ Paste 3 Math
Qutlining 3 3 Security [l

Diagram 4.11.9.1: Selecting Insert Diagram 4.11.9.2: Selecting the name of

Snippet snippet

The Code Editor and the Form Designer provide two different ways to work with the same
Visual Basic 2005 source file. The Code Editor allows working directly with the statements
that make up the application. The Form Designer presents a visual representation of the

forms and controls that are implemented by that code.
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When a component is double clicked, Visual Basic 2005 chooses one of its events to display
the code block for. The chosen event represents Visual Basic 2005's guess as to which event
is needed based on statistics. For example, the most common behavior with a Button is that
the user clicks it. So when a code editor window is opened by double clicking a Button, Visual
Basic 2005 shows that button's Click event. If another event or method is needed, first select
the component or the control whose event is needed as shown in diagram 4.12.1 and then
select the required event from Event / Method Name drop down list as shown in diagram

4.12.2.

Formi:vh: " Form1.vh [Design]
4¥Button L

[ (General)
“t% Form1

# (Form1Events)

Component I Class
Name

NN

ender As System.Cbject, ByVal e As Sy

FButtonl

1l _Load(ByVal sender As System.Cb]

ect, ByV

Jal e Rs Sy

>

Diagram 4.12.1: Component / Class Buttonl selected

Form1.vb| Form1.vb [Design]

,#Eutton 1

] Public

Class Fo

[T

RIS

3 tSizeChanged
# ContextMenuChanged
# ContextMenuStripChanged
# Controladded

# ControlRemoved
# CursorChanged

™| # Disposed

# Dockchanged

# Doubleclick

# DragDrop

# DragEnter

# DragLeave

# DragOver

# EnsbledChanged
# Enter

# FantChanged

# FareColorChanged
# GiveFeedback

# GotFocus

# HandleCreated

# HandleDestroyed
# HelpRequested

# Invalidated

# KeyDown

F KeyPress

F KeyUp

# Layout

e

Event/ Method
Name

& Leave
# LocationChanged

Diagram 4.12.2: Event / Method drop down list
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Running The Project

To check whether the project is running successfully, click P or press F5. If it runs
successfully (without any errors) the form will be presented as shown in diagram 4.13.

I "y

&= First Form E]@

MName

Address

[ Save l [ Cancel

Diagram 4.13: First Form at runtime
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